SMS delivery statuses are updated with a delay

Incident Report for TextMagic

Resolved

This incident has been resolved.
Posted Dec 11, 2020 - 09:28 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 11, 2020 - 06:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2020 - 06:40 UTC

Investigating

We have identified an issue causing the sent text messages delivery statuses to update with a delay.

Our development team is actively working on finding the cause of the issue and eliminating it.

All text messages are sent and delivered to the end recipients on time.
The issue affects only the delivery statuses seen in the TextMagic web app and sent via API callbacks.
Posted Dec 10, 2020 - 19:28 UTC
This incident affected: Web App and SMS API Gateway.