Textmagic service disruption
Incident Report for TextMagic
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 14:46 UTC
Investigating
Textmagic is currently experiencing delays and occasional unavailability due to issues with our server provider. We are doing our best to restore the service as quickly as possible.
Posted Oct 30, 2024 - 13:41 UTC