Messages from toll-free numbers may be delayed in the USA and Canada
Incident Report for TextMagic
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 07:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2023 - 19:08 UTC
This incident affected: Sending text messages (Outbound SMS).