Possible delays when importing contacts
Incident Report for TextMagic
Resolved
This incident has been resolved.
Posted May 04, 2021 - 05:20 UTC
Investigating
Some customers might experience longer than usual import times. Eventually, all imports will complete in the background. An email confirmation is sent to the account email when the import process is finished.

Our team is investigating the cause of the delays with the highest priority.

We will provide updates as soon as possible.
Posted May 03, 2021 - 19:53 UTC
This incident affected: Web App and Mobile App.