False email alert - "Login alert for your account"
Incident Report for TextMagic
Resolved
This incident has been resolved.
Posted May 20, 2024 - 06:24 UTC
Identified
We identified an issue with our login alert system, generating false error messages. Your account is completely secure and has not been accessed without your authorization.
Posted May 20, 2024 - 06:03 UTC